Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > General F150 Discussion
Sign in using an external account
Register Forgot Password?
Register Garage Photos FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read StoreVendor Directory

Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-10-2008, 11:40 AM   #1
Junior Member
 
Join Date: Jan 2008
Posts: 1
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question 99 f150 problems

I have a 99 f150 4wd 5.4 w/ a weird electrical problem .
accelerating down the road (doesnt matter what spd.) the tach and spedo will start to go wacky eng. will run rough trans will go to neutral , then stall , in order to restart while moving , put in nuetral you have to turn the key all the way back before it will start, but it will restart without problems. this prob is continuous. no matter hot / cold. tried a new reflashed computer, tried new ign sw . by the way there are no code's in the comp. or any other module. problem can be duplicated sitting still by power braking.
cardoc0001 is offline   Reply With Quote
Old 01-10-2008, 12:23 PM   #2
Junior Member
 
Join Date: Jan 2008
Location: Toms River, NJ
Posts: 1
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 99 f150 problems

Sounds like it could be a speed sensor problem in the transmission, especially if it's going into neutral by itself. Or, there's another transmission issue tied in with the magnetic pick-ups on the speedo & tach.
jeff99f150 is offline   Reply With Quote
Old 01-10-2008, 12:23 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
89 F150 Wiper problems rusheadcarerra 1987 - 1996 F150 64 11-18-2011 08:54 PM
A/C problems in 2007 f150 scumfrog General F150 Discussion 19 08-15-2011 12:45 PM
88 F150 Problems texasedition 1987 - 1996 F150 4 11-26-2008 09:07 PM
02 f150 power problems HELP fishinfool 1997 - 2003 Ford F150 0 07-24-2008 11:45 PM
92 F150 5.0 Starting Problems 92F1504X4EXTCAB Introductions 4 07-04-2008 08:06 AM

 

The Mustang Source

All times are GMT -4. The time now is 10:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.