99 f150 problems - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > General F150 Discussion
Log In 

99 f150 problems

Thread Tools Search this Thread
Old 01-10-2008, 12:40 PM   #1
Junior Member
Join Date: Jan 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question 99 f150 problems

I have a 99 f150 4wd 5.4 w/ a weird electrical problem .
accelerating down the road (doesnt matter what spd.) the tach and spedo will start to go wacky eng. will run rough trans will go to neutral , then stall , in order to restart while moving , put in nuetral you have to turn the key all the way back before it will start, but it will restart without problems. this prob is continuous. no matter hot / cold. tried a new reflashed computer, tried new ign sw . by the way there are no code's in the comp. or any other module. problem can be duplicated sitting still by power braking.
cardoc0001 is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE

Old 01-10-2008, 01:23 PM   #2
Junior Member
Join Date: Jan 2008
Location: Toms River, NJ
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 99 f150 problems

Sounds like it could be a speed sensor problem in the transmission, especially if it's going into neutral by itself. Or, there's another transmission issue tied in with the magnetic pick-ups on the speedo & tach.
jeff99f150 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle/Misfiring - HELP! (2006 F150 5.4L v8) carp104 2004 - 2008 Ford F150 19 10-14-2015 11:33 PM
New from Northeast NC hfd315 Introductions 3 09-05-2015 03:08 PM
Clutch problem? Not sure... Cpaulk 1987 - 1996 F150 1 09-04-2015 01:51 PM
F150 1996 Fuel Pumps will not Activate kenw Electrical 2 09-04-2015 08:06 AM
2001 Air conditioner intermitant Arizona Dave General F150 Discussion 0 09-02-2015 01:29 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -4. The time now is 08:24 PM.

Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.