95 f150 idle and missing problem - Ford F150 Forum - Community of Ford Truck Fans



95 f150 idle and missing problem

Reply
 
 
 
Thread Tools Search this Thread
Old 03-23-2011, 09:11 AM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2011
Location: texas
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default 95 f150 idle and missing problem

ok guys.My son totaled my 90 f150 5.0 so i got a 95 f150 5.0 with bad motor and put the motor out 90 in 95. all went in very easy. had to change out distributors and e few other parts. but now it is idling rough and sounds like it is missing a little . it has new plugs,wires,rotor,& cap.when you warm it up and give it some gas it seems like it smooths out but still won't run. anybody got any suggestions?
blueheart is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough Idle/Misfiring - HELP! (2006 F150 5.4L v8) carp104 2004 - 2008 Ford F150 39 08-09-2016 07:32 PM
4.2 problems mjs757 1997 - 2003 Ford F150 2 09-05-2015 10:31 AM
High idle issue Aleakydishwasher 4.6L 3V 0 09-04-2015 11:23 AM
What should be the rpm idle? crazyrwe General F150 Discussion 3 09-02-2015 10:50 PM
High idle when warm SCTA Tech 1987 - 1996 F150 1 09-02-2015 08:29 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:40 PM.


Copyright 2006 - 2016 F150Forum.com