Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > Maintenance Shop
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-04-2012, 06:19 PM   #1
Junior Member
 
Join Date: Oct 2012
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default No power to factory installed trailer towing plug

I have a 2009 f150 fwd XLT. I keep having a problem with power to the trailer light recpticals. 7pin/ 4 pin. The first time I had the problen with a blown fuse for the trailer light relay feed. I replaced that one miself. The second time I had the problem, all fueses checked good so I took it to the dealer. Thy repaired the problem saying they rplaced a fuse but they couldn't tell me which one because the mechanic was at lunch. I checked the plug and had power. One year later the first time I went to tow a trailer again here we go again, no power again. I checked all the fueses listed in the owners manual with an ohem meter and the listed fueses check good. Is there a fuse in the system somewhere listed under a different name that can affect the power to this plug.
tommyga is offline   Reply With Quote
Old 10-04-2012, 06:33 PM   #2
Senior Member
 
Join Date: Jul 2011
Location: Tonopah. AZ.
Posts: 2,215
Mentioned: 1 Post(s)
Thanked 187 Times in 126 Posts
Feedback Score: 0 reviews
Default

There is a 30amp fuse and relay in the power dist box marked TT power. This is the fuse that controls the ignition on power to the 7 pin. It has nothing to do with the trailer lights its sole purpose is to charge the trailer battery for RV power or break away switch for trailer brakes.
bubbabud is offline   Reply With Quote
Old 10-04-2012, 10:39 PM   #3
Junior Member
 
Join Date: Oct 2012
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

It is the stop turn and tail lights pins that do not have power
tommyga is offline   Reply With Quote
Old 10-04-2012, 10:39 PM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 09:10 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.