Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > Maintenance Shop
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 09-19-2012, 05:54 AM   #1
Junior Member
 
Join Date: Sep 2012
Posts: 18
Mentioned: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Question Horn not working strange problem

1993 f150 xl 4x4 4.9L no cruse. My horn relay is not tripping, if I jump the relay contacts without the relay installed the horns sound so the system is good from the relay to the horns. I have tryed: 3 different relays, cleaned all 3 firewall connectors, jumped the wires behind the horn button with no affect, cleaned (very well) the contacts between the steering wheel and steering column, tripple check all fuses and checked what I can reach of the wires. I am out of ideas. Please
Motorman is offline   Reply With Quote
Old 09-26-2012, 11:41 PM   #2
Senior Member
 
Join Date: Sep 2012
Location: Texas
Posts: 270
Mentioned: 0 Post(s)
Thanks: 17
Thanked 39 Times in 30 Posts
Feedback Score: 0 reviews
Default

This just a general post about relays, to trip they need 2 things:

1) +12vdc
2) ground

add 1 at a time till it works - then trace the missing signal
hetman is offline   Reply With Quote
Old 10-07-2012, 05:25 AM   #3
Junior Member
 
Join Date: Sep 2012
Posts: 18
Mentioned: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Default

Found the falt, no ground coming out of the wireing loom behind the dash that routs to the horn button. I still don't know where the brake in the wire is but I spliced in a new ground and the horn works.
Motorman is offline   Reply With Quote
Old 10-07-2012, 05:25 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 05:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.