Horn doesn't work, but cruise control does? - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > Maintenance Shop
Log In 


Horn doesn't work, but cruise control does?

Reply
 
 
 
 
Thread Tools Search this Thread
Old 02-14-2010, 04:48 PM   #1
Member
 
Join Date: Jan 2010
Location: Forks Wa
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Horn doesn't work, but cruise control does?

My 1997 f-150 horn decided not to work all of a sudden. I've done a little research into this subject and usually when the horn doesn't work then the cruise control stops working also. I've checked the horn fuse and it's fine. Could this still be the clock spring?
Phaeton is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 02-14-2010, 07:02 PM   #2
blue blood
 
Join Date: Nov 2009
Posts: 331
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Default

if you look under the dash driver side there is a plug 4 to 6 wires right side of steering column the dark blue is the horn will be 12 volt till you push the horn .so if you ground it and it honks its the clock spring.





badcat is offline   Reply With Quote
Old 02-14-2010, 07:07 PM   #3
Senior Member
 
metropolis909's Avatar
 
Join Date: May 2009
Location: webster ma
Posts: 1,399
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to metropolis909
Default

my horn stopped working and i went underneath and hit the horn with a hammer and works mint haha
metropolis909 is offline   Reply With Quote
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 08:05 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.