Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > Maintenance Shop
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 05-06-2014, 09:21 PM   #1
Junior Member
 
Join Date: Mar 2013
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 1994 f150 5.0 code 332

I have code 332 showing up and listed is what I have done. First off I changed the egr solenoid, have vacuum to the solenoid while the truck is running. I also have vacuum present at the coffee can and present at the egr valve small green line when the truck is warm and at half throttle. I also placed another line in the egr port itself and could hear the diaphragm flexing as I physically sucked and blowed into the line. The coffee can appears to be okay with no holes but I'm lost at this point with just replacing all the vacuum lines. Ohh I also checked the voltage going to the solenoid and have 12 volts present. The truck does not run rough at idle or anytime at that matter and gets about 16 mpg. It's 2wd short bed and has 160,000 miles. If someone could please point me in another direction I would greatly appreciate not getting any more grey hair. Haha thanks guys.
daniel048225 is offline   Reply With Quote
Old 05-06-2014, 09:22 PM   #2
Junior Member
 
Join Date: Mar 2013
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Also what is the best cleaner to use and try to run through te system if any?
daniel048225 is offline   Reply With Quote
Old 05-06-2014, 09:40 PM   #3
Junior Member
 
Join Date: Mar 2014
Location: Iowa
Posts: 8
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 332 code

i have a 95 5.8L and i have the same issue, i smoke tested it and no smoke came out, along with taking the lines off and seeing if they were cracked, the can has no holes or cracks but my light comes on only when moving though, i can be idled for an hour with no light, but i move 2 feet and its on, doesnt affect performance, and for me, The truck runs and drive, a vacuum leak isn't going to hurt anything, so why bother with it anymore
Justin5.8 is offline   Reply With Quote
Old 05-06-2014, 10:15 PM   #4
Junior Member
 
Join Date: Mar 2013
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

You are right but if it would help me get another .5 mpg than its worth it.
daniel048225 is offline   Reply With Quote
Old 05-06-2014, 10:15 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 06:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.