Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > Engine / Drivetrain Talk
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 06-04-2014, 09:00 PM   #1
Junior Member
 
Join Date: Jul 2012
Location: HV-GB,NF,CAN
Posts: 20
Mentioned: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default No Reverse!!!

Backing into my driveway a couple days ago I heard a pretty noticeable "thud" when I put her in reverse. Checked out up underneath when I pulled in and stopped, couldn't physically see anything so I tried her in drive then reverse a few times and she seemed fine. Gets home from work today and puts her in reverse and she idles back but when you press the throttle she just revs like she's in neutral. Anyone else ever have this problem ?? 07 XLT 5.4
charles13 is offline   Reply With Quote
Old 06-15-2014, 07:48 PM   #2
Junior Member
 
Join Date: Jun 2014
Posts: 10
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I have the same problem. reverse slips really bad. had it checked out and they told me it needs rebuilt. doesn't seem like much of a diagnoses though. it would be nice to know exactly whats wrong.
musclemike is offline   Reply With Quote
Old 07-01-2014, 08:17 PM   #3
Junior Member
 
Join Date: Jul 2012
Location: HV-GB,NF,CAN
Posts: 20
Mentioned: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

Had to change my tranny out, found a used one from a scrapyard with 85,000 kms on it for 1400, got it shipped in for free (with an awesome hookup).. Altogether had to pay about $2200 to get it fixed, but atheist now it works lol
charles13 is offline   Reply With Quote
Old 07-02-2014, 12:25 AM   #4
Fleet Technician
 
Rnlcomp's Avatar
 
Join Date: Feb 2013
Location: Big Easy
Posts: 7,416
Mentioned: 43 Post(s)
Thanked 1,224 Times in 983 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by musclemike View Post
it would be nice to know exactly whats wrong.
It's broken/worn out take your pic. Just like a manual transmission uses a clutch disk to apply engine power to the wheels via the tranny, so does the auto trans.

Machines wear out, clutch disks wear down, etc....

.
__________________
2013 XLT S-cab 5.0
Rnlcomp is online now   Reply With Quote
Old 07-14-2014, 12:49 PM   #5
Senior Member
 
ibd2328's Avatar
 
Join Date: Mar 2012
Posts: 7,320
Mentioned: 65 Post(s)
Thanked 318 Times in 265 Posts
Feedback Score: 2 reviews
Default

Got mine changed out for 200 bucks.
__________________
ibd2328 is online now   Reply With Quote
Old 08-03-2014, 02:33 PM   #6
Junior Member
 
Join Date: Jun 2014
Posts: 10
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

mine did the same thing. I tore the trans apart and found the reverse piston return spring broken.
musclemike is offline   Reply With Quote
Old 08-03-2014, 02:33 PM
 
 
 
Reply


Tags
reverse trouble, tranny issue

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 03:44 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.