Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > Engine / Drivetrain Talk
Sign in using an external account
Register Forgot Password?
Register Garage Photos FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read StoreVendor Directory

Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-23-2008, 10:06 AM   #11
NGM
Resident A-hole
5 Year Member
 
NGM's Avatar
 
Join Date: Feb 2007
Location: Tallahassee
Posts: 4,098
Mentioned: 0 Post(s)
Thanks: 0
Thanked 19 Times in 17 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to NGM
Default

Go back in and be firm, but polite. Don't raise your voice. Tell them, don't ask, "that there is a problem. They will find and fix the problem. They will give you a loaner until the problem is fixed. You need a truck and they will provide a truck." If they say they can't do that its time to get a little louder.. no cussing, just make sure any potential customers in the dealership can hear you. Let them know that the service dept is incompetient (sp) and that buying a vehicle there would be a mistake. Then go to another dealer. Call Ford corporate and tell them the problems you are having. Let them know that you are very unhappy. Tell them that you NEED a truck, they NEED to give you a loaner. If they still will not help you contact a lawyer. I am not saying sue them, just get what you deserve. A good running truck and repaired under warranty.
__________________
SCT Tuner - 400.00
Jaws Racing Tunes - 150.00
Beating the wifes new GM truck - Priceless
http://www.jawsracing.net/
NGM is offline   Reply With Quote
Old 01-23-2008, 01:12 PM   #12
Junior Member
 
Join Date: Jan 2008
Posts: 6
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 5.4 motor there junk

Quote:
Originally Posted by coolcontractor View Post
My '07 Lariat with the 5.4 has a pinging problem. It has 7,000 miles now but has pinged since new. Dealer has looked at it twice and hasn't fixed it. It pings and stumbles at about 2,000 RPM's with a slight load on the engine. Has anyone had this problem and found a cure? Please respond.

Yes mine went in to I have a 05 5.4 liter fx4 f150 had a slight ping or tick whatever u want to call it. The ford service told me the motors cam timing takes a **** with sprockets they fixed it under warrenty. They gave me the new revised parts for 08. I got half a new motor my truck only has 42000 on it that shouldnt have happend. im very light on it only put the pedel to the floor once ! Two days after they fixed it im getting a whlisting or howling out of it when press on the gas. So its going back again. And not to mention my motor had a another problem they had to fix 6 months ago. The new f150 in my eyes is crap. This is my first ford and my last ford. Never buy AGAIN!! I really should have listend to the people telling me they were a peice of junk I mean serious 42000 miles need new motor what a joke.
my ford sucks is offline   Reply With Quote
Old 01-23-2008, 01:44 PM   #13
Junior Member
 
Join Date: Jan 2008
Posts: 6
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default whlisting 5.4 motor

I have an 05 f150 fx4 5.4 liter got it in jan 07 this thing is a nightmare. I had a motor problem six months ago (position sensor) was junk at least thats what the delear said. About 2 weeks ago I noticed like a ping or tick took it in said my vairble cam timing and sprockets were crap. I said yeah right this motor has low miles under 50,000 and I dont beat my truck floored it once never hauled more than 1,000 pounds and never towed a thing. So they basicly gave me half a new motor minus the head. But now two days after the flipin motors making a whlisting or like a howling noise. Please any body out there have u had any luck with the late model fords TELL ME HOW YOUR DOING IT PLEASE!! I just want to fix and sell Cut my losses now my warrnty just ran out I dont want to go over this again in 20,000 miles please give feed back
my ford sucks is offline   Reply With Quote
Old 01-23-2008, 06:05 PM   #14
KAC Shooter
5 Year Member
 
Join Date: May 2007
Location: West Palm Beach, FL
Posts: 3,191
Mentioned: 0 Post(s)
Thanks: 0
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by my ford sucks View Post
I have an 05 f150 fx4 5.4 liter got it in jan 07 this thing is a nightmare. I had a motor problem six months ago (position sensor) was junk at least thats what the delear said. About 2 weeks ago I noticed like a ping or tick took it in said my vairble cam timing and sprockets were crap. I said yeah right this motor has low miles under 50,000 and I dont beat my truck floored it once never hauled more than 1,000 pounds and never towed a thing. So they basicly gave me half a new motor minus the head. But now two days after the flipin motors making a whlisting or like a howling noise. Please any body out there have u had any luck with the late model fords TELL ME HOW YOUR DOING IT PLEASE!! I just want to fix and sell Cut my losses now my warrnty just ran out I dont want to go over this again in 20,000 miles please give feed back

Both Ford mod motor'd vehicles I own run just fine. I bet your cam phasers had the issue and you most likely have some vac leak, why dont you take the truck back in and talk to the Service Manager or dealership owner?
__________________
2013 Ecoboost Black on Black FX2 SCREW
2007 Black on Black SCAB sold 14 Sept 13
1996 Thunderbird LX 14.17@98mph sold 13 Oct 12
obusnizzle is offline   Reply With Quote
Old 01-23-2008, 09:06 PM   #15
2007 SuperCrew
5 Year Member
 
Join Date: Jan 2008
Location: Anaheim, CA
Posts: 81
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Totally BOGUS.....

Glenn
http://www.billetmyride.com/ford-f15...eadlights.html
http://www.billetmyride.com/ford-f15...eadlights.html
__________________
2009 SuperCrew - 22" Wheels, Mesh Grille, Smoked LED Tail Lights, Smoked LED 3rd Brake Light
2007 SuperCrew - Chrome Mesh Grill, Projector Headlights, ATS Painted Running Boards - LED Tail Lights - LED 3rd Brake Light - Jensen Head Unit
MyTightRide.com
MyTightRide is offline   Reply With Quote
Old 01-24-2008, 02:01 AM   #16
KAC Shooter
5 Year Member
 
Join Date: May 2007
Location: West Palm Beach, FL
Posts: 3,191
Mentioned: 0 Post(s)
Thanks: 0
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
Default

why do you put advertising links in everyone of your posts? that borders on spamming and you need to get authorization from the site admin to do stuff like that. You are making a buck of their bandwidth.
__________________
2013 Ecoboost Black on Black FX2 SCREW
2007 Black on Black SCAB sold 14 Sept 13
1996 Thunderbird LX 14.17@98mph sold 13 Oct 12
obusnizzle is offline   Reply With Quote
Old 02-02-2008, 02:39 PM   #17
Junior Member
 
Join Date: Nov 2007
Location: south carolina
Posts: 23
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Jerm
Default

you guys are making me nervous because my truck is reaching 100k and i dont want to have to replace an engine. you are right FORD needs to do better than that. they need to recall some items..
Jerm is offline   Reply With Quote
Old 02-15-2008, 08:55 PM   #18
Member
5 Year Member
 
Join Date: Feb 2008
Posts: 32
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 'Ping in engine'

I have seen this posted on other forums, apparently there were a few engines assembled with defective crankshaft thrust bearings which wore out very early in life. From what I have read if an engine is affected it occurs very early in its' life and will be in warranty, and yes, Ford wants the entire engine replaced from what I have seen.
sam1947 is offline   Reply With Quote
Old 03-03-2008, 09:39 PM   #19
Junior Member
5 Year Member
 
mikeltn's Avatar
 
Join Date: Feb 2008
Location: Manassas, VA
Posts: 18
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Oh, how I feel everyones pain here. I have an 05 Scab 5.4L FX4. At 57000 miles I wound up throwing a rod. I originally bent it. Had no choice but to limp it back home. I got t to the dealer the next day. Took them 3 days to diagnose a bad fuel rail as the problem. Needless to say I would not pick it up or pay until they got a second opinion. I had an extended warranty, so they sent an adjuster to evaluate it. We were all standing in the garage and the adjuster asked them to start it. The rod broke in half with enough force to shoot one one piece out of the bottom of the block and another half way through the top end. $11k in parts and labor and three more visits to get everything working right.
__________________
'05 FX4 - 5.4L Long Block , Auto - Ext Cab - 6'5" Bed
Dual XDVD8285 6.5" Touchscreen
Front 6.5" Kicker RS Component
Rear 10" Kicker CompVT Shallow Mount Subs
mikeltn is offline   Reply With Quote
Old 03-08-2008, 07:09 PM   #20
Senior Member
 
rplatt56's Avatar
 
Join Date: Mar 2008
Location: Florida
Posts: 516
Mentioned: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Default

I had the same problem with my 07 5.4... I didnt notice it until i put a K&N filter on. I fixed the problem my self by increasing the intake tube coming from the side wall from 2" to 3". You can find this fix on the mod page. Also gave me much better throttle response. Sometimes you wonder what the engineers are thinking.....
rplatt56 is offline   Reply With Quote
Old 03-08-2008, 07:09 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C problems in 2007 f150 scumfrog General F150 Discussion 19 08-15-2011 12:45 PM
2007 f150 A/C problems continue scumfrog General F150 Discussion 9 08-15-2011 09:08 AM
Engine problems 302dude 1987 - 1996 F150 18 08-25-2008 05:12 PM
engine problems Munson 1987 - 1996 F150 1 05-23-2008 01:52 PM
2007 Ford 150 5.4L Engine Noise JNP2000 Engine / Drivetrain Talk 6 02-22-2008 09:27 AM

 

The Mustang Source

All times are GMT -4. The time now is 08:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.