Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > Engine / Drivetrain Talk
Sign in using an external account
Register Forgot Password?


Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 03-15-2009, 03:48 PM   #1
Junior Member
 
Join Date: Mar 2009
Posts: 3
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 04' 5.4 running rough at idle

Need some help guys. I have an 04 with a 5.4 that has recently started idling rough when the truck is at stop lights and such. The engine light came on for a short time but went off before I could my mechanic friend to look at it. The best I can explain it is the engine will start sounding like it's knocking while the truck starts to shake, and a couple times it's died. It runs just fine once you give it gas and haven't noticed anything odd while I'm driving. Like I said, the check engine light went off for about 3 or 4 days now but just today it's started idling funny again (without the engine light coming back on).

I really want to avoid a dealership and I've got a week and a half until we are suppose to drive from Indianapolis to Florida. Any ideas?

Thanks in advance!
uaw1111 is offline   Reply With Quote
Old 03-15-2009, 03:49 PM   #2
Junior Member
 
Join Date: Mar 2009
Posts: 3
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Oh, the truck has roughly 63K miles on it and I've never replaced the plugs, wires, ect.
uaw1111 is offline   Reply With Quote
Old 03-22-2009, 06:27 PM   #3
Member
 
Join Date: Feb 2009
Location: AB, CA eh!
Posts: 93
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by uaw1111 View Post
Oh, the truck has roughly 63K miles on it and I've never replaced the plugs, wires, ect.
I think you just answered your own question?
st8ic is offline   Reply With Quote
Old 03-22-2009, 06:29 PM   #4
3wV
Member
 
Join Date: Mar 2009
Posts: 82
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Air cleaner. And if you are going on a trip, take st8ic's suggestion before that gas guzzling trip, you change the fan belt before it blows with your new found plugs/wires/etc.
3wV is offline   Reply With Quote
Old 03-22-2009, 07:30 PM   #5
Junior Member
 
Join Date: Mar 2009
Posts: 3
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Thanks guys! I replaced the air cleaner, plugs, and wires this weekend and we'll see how it goes.
uaw1111 is offline   Reply With Quote
Old 03-22-2009, 08:36 PM   #6
Member
 
incogmeo's Avatar
 
Join Date: Feb 2009
Location: Central Ohio
Posts: 79
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

If that doesn't fix it, I suggest taking it someplace like Advance Auto or Autozone and have them hook it up to their reader. They do it for free.

Another thought ... did you recently wash your engine or engine compartment ??
__________________
04 XLT SCab 5.4, 2/3 Eibach drop, 285x50x20's on VLine Wheels
incogmeo is offline   Reply With Quote
Old 03-24-2009, 08:06 PM   #7
Junior Member
 
Join Date: Mar 2009
Posts: 1
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default rough idle at crank

i am having problems with when i crank my '03 ford f150 fx4 it idles really low then comes back up....is it just a tick or is something wrong? thanks for the input
fordsupercrewguy is offline   Reply With Quote
Old 03-24-2009, 10:15 PM   #8
Junior Member
 
Join Date: Dec 2008
Posts: 17
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I have same problems, got it fixed, run smooth now, I bough a caburator cleaner , reemove the air intake and sprayed into the FLAB ( don't know what it call) but control how much air into the engine, swiped all the black carbon build up with a cloth, sprayed again, and keep the engine idle @ 2000 RPM while spraying it, 5 minute later, put everything back in give it a test drive, run smooth till now almost aweek later, ran even better.
For your Trip if you can fix it in time, can always drive with one foot on break and other on gas, sort of like driving stick, keep that idle up while breaking, i did that for few days before i fixed it.
good luck hope this'd help
Troi_oi is offline   Reply With Quote
Old 03-25-2009, 11:36 AM   #9
Junior Member
 
Join Date: Mar 2009
Location: Orlando, Florida
Posts: 3
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I am having same problem with my 05, changed air filter and it was totally black, changed everything else and it is still idling low and some times dies? What else?
angels ride 05 is offline   Reply With Quote
Old 03-28-2009, 09:52 AM   #10
Junior Member
 
Join Date: Dec 2008
Posts: 17
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by angels ride 05 View Post
I am having same problem with my 05, changed air filter and it was totally black, changed everything else and it is still idling low and some times dies? What else?
Try this, go buy cab cleaner, spray bottle similar to DW40, pull out the intake pipe ( see pic ) keep idle @2000 and spray it in about minutes or so, shut off the engine, swipe off the carp in there, start engine tthen spray again, then clean it, take it for a test drive and go nut, then see if it work, if not then it could be other problem
Attached Images
 
Troi_oi is offline   Reply With Quote
Old 03-28-2009, 09:52 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle oldmanb777 Engine / Drivetrain Talk 5 05-10-2009 01:03 AM
Rough Idle Caper 1997 - 2003 Ford F150 3 12-17-2008 07:04 AM
Rough idle 4.6????? 08STX4X4 Engine / Drivetrain Talk 4 05-21-2008 11:36 PM
Rough Idle Ncrager Engine / Drivetrain Talk 9 05-12-2008 09:55 AM
Rough running 5.4 Need help bad boyfromdixie88 General F150 Discussion 4 01-18-2008 08:06 PM

 

The Mustang Source
All times are GMT -4. The time now is 04:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.