Help! - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > Engine / Drivetrain Talk > 6 Cylinder Engines > 4.2L
Log In 


Thread Tools Search this Thread
Old 10-03-2012, 02:09 PM   #1
Junior Member
Join Date: Oct 2012
Location: Huntsville, AL
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Help!

Bought this truck from dealer with 221K on it, have 2 other F-150's but with in-line 6's that have over 300K on them. This is my first experience with a V-6.
Truck ran fine on initial drive out, then began a slight miss @ idle.
Gas consumption escalated very much!! Put on computer. Shows bad EGR valve & a miss on 2 cylinders. Exp. Mechanic bud says there's a sensor on exhaust to check the EGR valve & most of the time the EGR is OK but the sensor leads have burned away.
Anybody have any knowledge? Could this be causing the miss & poor mileage? Need to do a compression check, one guy says a cracked head, but no oil in water or water in oil, nor steam out back.
Do not have print out of codes from shop, but may can get.
Any Help on where to begin would be appreciated.
rebranger is offline   Reply With Quote
Join F150 Forum

Join Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that is a great community to join. Best of all it's totally free!

Join Today! - Click Here JOIN FOR FREE

Old 10-24-2012, 09:39 PM   #2
Senior Member
5 Year Member
ddbrown's Avatar
Join Date: Dec 2009
Posts: 115
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews

Never had this issue but mine has only 119K
2003 V6 (4.2L) XLT Super Cab
Limited Slip Diff 3.55
128,500 (Aug 2014)
ddbrown is offline   Reply With Quote
Old 03-21-2013, 10:03 PM   #3
Junior Member
Join Date: Mar 2013
Posts: 15
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

depending on what year yours is i got a 97 with a 4.2 thats got a misfire on #3 and its a bad coil pack i to got bad gas milage but the only code i get is miss fire on #3 going down the road its fine except every now and then the engine light will flash which means its miss firing all i need is a new coil pack but you might have the cop style (coil over plug) in which case find out what one it is and replace them
porath1969 is offline   Reply With Quote

4.2l, 6 cyl, codes, egr valve

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -4. The time now is 08:24 PM.

Copyright 2006 - 20011
This site is in no way affiliated with the Ford Motor Company.