What did you do to your truck today? - Page 1140 - Ford F150 Forum - Community of Ford Truck Fans



What did you do to your truck today?

Reply
 
 
 
Thread Tools Search this Thread
Old 07-08-2014, 11:06 PM   #11391
Senior Member
 
F-ReV's Avatar
 
Join Date: Aug 2012
Location: New Jersey
Posts: 758
Thanks: 0
Thanked 27 Times in 26 Posts
Default

Installed new EGR Valve and throttle cable today
F-ReV is offline   Reply With Quote
Old 07-10-2014, 12:27 AM   #11392
Senior Member
 
Big Pete's Avatar
 
Join Date: Oct 2011
Location: Gilbert, AZ
Posts: 698
Thanked 6 Times in 6 Posts
Default

I am hearing a squeal when I am driving but only when I slightly hit the accelerator. My power steering pump pulley is slightly loose. I can move it in and out a little. Can this be it? If so, should I replace it with a new or remanufactured?

Sorry if this is in the wrong place but it seems that you guys here know your **** and I value your opinions.

Any thoughts would be greatly appreciated.
Big Pete is offline   Reply With Quote
Old 07-10-2014, 05:44 AM   #11393
Senior Member
 
Forge-World-FORD's Avatar
 
Join Date: Jun 2011
Posts: 2,364
Thanks: 0
Thanked 101 Times in 98 Posts
Default

Quote:
Originally Posted by Big Pete View Post
I am hearing a squeal when I am driving but only when I slightly hit the accelerator. My power steering pump pulley is slightly loose. I can move it in and out a little. Can this be it? If so, should I replace it with a new or remanufactured?

Sorry if this is in the wrong place but it seems that you guys here know your **** and I value your opinions.

Any thoughts would be greatly appreciated.
Generally this thread is stuff you've done to your truck (hence the title). If you need help you should start a new thread for it. Does it do it when parked and you hit the gas or only while moving? Just something to include when you start your thread.
Forge-World-FORD is offline   Reply With Quote
Old 07-10-2014, 10:40 PM   #11394
Senior Member
 
Big Pete's Avatar
 
Join Date: Oct 2011
Location: Gilbert, AZ
Posts: 698
Thanked 6 Times in 6 Posts
Default

Quote:
Originally Posted by Forge-World-FORD View Post
Generally this thread is stuff you've done to your truck (hence the title). If you need help you should start a new thread for it. Does it do it when parked and you hit the gas or only while moving? Just something to include when you start your thread.
Sorry, I will start a thread.
Big Pete is offline   Reply With Quote
Old 07-11-2014, 02:59 PM   #11395
Senior Member
 
VickMacky's Avatar
 
Join Date: Jun 2014
Posts: 459
Thanked 29 Times in 29 Posts
Default

Replaced my fan clutch and damn near broke by thumb in the process (my stupidity).

Also spent 2 hours polishing my rims from this...


To this...
VickMacky is offline   Reply With Quote
Old 07-11-2014, 03:21 PM   #11396
Senior Member
5 Year Member
 
BROWNINGFX4's Avatar
 
Join Date: Apr 2010
Location: Panama City, Florida
Posts: 5,868
Thanked 28 Times in 28 Posts
Default

Quote:
Originally Posted by VickMacky View Post
Replaced my fan clutch and damn near broke by thumb in the process (my stupidity). Also spent 2 hours polishing my rims from this... To this...

What did you use? Looks great!
BROWNINGFX4 is offline   Reply With Quote
Old 07-11-2014, 04:11 PM   #11397
Senior Member
 
VickMacky's Avatar
 
Join Date: Jun 2014
Posts: 459
Thanked 29 Times in 29 Posts
Default

Quote:
Originally Posted by BROWNINGFX4 View Post
What did you use? Looks great!
Thanks! Mr. Metal polish. There are still a few spots that will take more than my hands to get off but it's a major improvement.
VickMacky is offline   Reply With Quote
Old 07-14-2014, 06:49 PM   #11398
It's a Canadian thing eh!
 
sylver91's Avatar
 
Join Date: Nov 2010
Location: Ontario, living across a hay field
Posts: 6,662
Thanked 185 Times in 180 Posts
Default

After sitting for 3 days, truck was stone dead. No click, no lights no nothing so I had to boost to get it started. Found a draw which lead to my Scan Gauge not shutting off somehow and had a 2amp pull on the system.
sylver91 is offline   Reply With Quote
Old 07-14-2014, 07:01 PM   #11399
Salvage Yard Pro
 
unit505's Avatar
 
Join Date: Feb 2012
Location: Keithville, La
Posts: 2,541
Thanked 120 Times in 107 Posts
Default

Well.............not my Ford, but my kids new used '03 Sierra 4x4. Been plenty busy getting it ready for the road and trail. Have to fix the AC high pressure line and it will be pretty much done. I can't work on this stuff too often. Almost leaves me wanting one. He got his insurance check from the Friday the 13th head on collision and nearly had enough left to cover all of the upgrades. Completely new front suspension, brushguard/winch brand new, light bar like Dad! Lol. I still have to install the BullyDog Programmer.

Now it's time for me to get the oil leak fixed on my truck. I added the tee for the mechanical oil pressure gauge and the stock electric sending unit. Now the sending unit is leaking again. I'm going to cap it off and run the mechanical only. Hopefully I'll get it done this weekend.
unit505 is offline   Reply With Quote
Old 07-14-2014, 07:05 PM   #11400
Senior Member
5 Year Member
 
smcox1's Avatar
 
Join Date: Dec 2010
Posts: 6,187
Thanked 447 Times in 403 Posts
Default

Put a 50" above my windshield with mounts that go into the door jamb.
smcox1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Engine Stalls at higher rpms Frank Snell General F150 Discussion 3 11-12-2016 03:31 AM
New to site, New to trucks, Lots of dumb questions inside! Cpt.America 2009 - 2014 Ford F150 51 11-06-2016 12:58 PM
Unexpectedly got 275/70R18 BFG Ko2's today at lunch! doolin64 2015 - Present Ford F150 18 10-24-2016 06:13 AM
Did a Tune Up WOW! LEBScrew13 2009 - 2014 Ford F150 18 09-04-2015 05:56 PM
Egr tube hitting firewall? ruckus226 General F150 Discussion 8 09-03-2015 11:22 AM


Tags
linkage, transfer case

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:52 AM.


Copyright 2006 - 2016 F150Forum.com