Water Pump Removal & Installation 5.0 EFI - Ford F150 Forum - Community of Ford Truck Fans



Water Pump Removal & Installation 5.0 EFI

Reply
 
 
 
Thread Tools Search this Thread
Old 03-27-2011, 01:44 AM   #1
Junior Member
Thread Starter
 
hkr321hkr's Avatar
 
Join Date: Feb 2011
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default Water Pump Removal & Installation 5.0 EFI

Start by removing fan bolts and shroud. Then remove your belt with a 5/8. Remove the 3 AC top bolts and all Power steering bracket bolts and move to the side. I hang them with a bungy cord from the hood. Drain Radiator then remove hoses from water pump. Tuck hoses out of the way. Remove all studs/ bolts and remove water pump assy. Be careful not to remove spacer plate or you will have to change that gasket as well. Ive done this twice without having to change the gasket between engine block and spacer plate. (Stupid Ford) Cant wait to get a electric water pump. Always use gasket sealer thin and lightly to fill any pitting and guaranty no leaks. The reason the bearings go bad in my case I believe is because of the stupid fan being bolted to it. If it has the slightest wobble it will destroy the water pump bearing every time. I suggest buy (2) 10 or 12 inch electric fans like I am. I will be posting that soon too! I hope this helps. Installation is reverse and make sure to clean everything well prep with starter fluid on a rag before gasket sealer is applied. I clean all bolt threads and apply anti-seize on every bolt! If you notice all gasket areas are not exactly doing anything so I did not apply sealant there. Just being the ocd neat mechanic I am lol
Attached Images
     
hkr321hkr is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'95 F150 5.0L fuel system woes RetTankMech Drivetrain 4 07-15-2016 10:17 PM
Replaced front fuel pump; still not working spinningchurro 1987 - 1996 F150 6 10-23-2015 11:01 PM
Anyone with Rancho rs5000? ericantonio Suspension & Brakes 3 09-05-2015 01:57 AM
Hey everyone Brandyn193 Introductions 1 09-04-2015 05:06 PM
4.6L Ticking at startup Craig4937 2004 - 2008 Ford F150 4 09-03-2015 10:29 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:18 PM.


Copyright 2006 - 2016 F150Forum.com