Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-04-2011, 07:28 PM   #1
Member
 
cutt73's Avatar
 
Join Date: Aug 2011
Posts: 36
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Smell gas on passanger side of motor?

Just changed the rear fuel pump and now I smell gas on passenger side of motor, wth is causing this? Could it be the plugs not burning all of the fuel? Or something more ? The truck runs like a champ, idles at 7-800 94 302 110,000 miles I'm getting about 16 to 17 miles to the gallon! What should I do?
cutt73 is offline   Reply With Quote
Old 10-04-2011, 07:31 PM   #2
Member
 
cutt73's Avatar
 
Join Date: Aug 2011
Posts: 36
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Ps I also smell it from the ac vents. Thanks
cutt73 is offline   Reply With Quote
Old 10-04-2011, 07:45 PM   #3
Ahahahahahaha!!!
 
Buddhaman's Avatar
 
Join Date: Jan 2010
Location: Ethiopia, Mongoria
Posts: 12,348
Mentioned: 5 Post(s)
Thanks: 1
Thanked 12 Times in 7 Posts
Feedback Score: 0 reviews
Default

Well you could always use the Bic method.... There's the possibility there's a leak now that everything is getting full pressure
__________________
Quote:
Originally Posted by opinyawn View Post
So what you are saying that the U.S. should invade Mars and plant marijuana there and sell it to Muslims until their culture collapses and we are then dominant and have the resources to build yet another Death Star! Well, let me tell you how wrong you are for thinking that!
Buddhaman is online now   Reply With Quote
Old 10-04-2011, 07:47 PM   #4
Member
 
cutt73's Avatar
 
Join Date: Aug 2011
Posts: 36
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I let it run and I searched for leaks, but it is dry
cutt73 is offline   Reply With Quote
Old 10-04-2011, 10:40 PM   #5
Member
 
cutt73's Avatar
 
Join Date: Aug 2011
Posts: 36
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Anyone?
cutt73 is offline   Reply With Quote
Old 10-04-2011, 10:48 PM   #6
Member
 
Hunter150's Avatar
 
Join Date: Sep 2011
Location: Allentown, Pa
Posts: 60
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I had that exact problem. I changed my plugs and wires about two weeks ago and haven't smelled any since then. Not sure if that's what your problem is but it may be.
Hunter150 is offline   Reply With Quote
Old 10-04-2011, 10:56 PM   #7
Member
 
cutt73's Avatar
 
Join Date: Aug 2011
Posts: 36
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Thanks for the input, I appreciate it
cutt73 is offline   Reply With Quote
Old 10-05-2011, 06:20 PM   #8
Rrj
Junior Member
 
Join Date: Sep 2011
Posts: 11
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I had the same problem, was the deteriorated hose to the fuel evaporator canister
Rrj is offline   Reply With Quote
Old 10-05-2011, 07:40 PM   #9
Member
 
cutt73's Avatar
 
Join Date: Aug 2011
Posts: 36
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I will take a look at it, thanks
cutt73 is offline   Reply With Quote
Old 12-02-2011, 09:11 PM   #10
Junior Member
 
Join Date: Jul 2011
Posts: 2
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Was that the hose to the canister under the spare or the hose that goes to the purge solenoid??
Thanks.
cynot is offline   Reply With Quote
Old 12-02-2011, 09:11 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any 1 got wheel spacers?? Also my passanger side wheel isue.... allanmathews 1987 - 1996 F150 4 03-14-2011 09:40 PM
Passanger side tow mirror plastic is cracked...can anyone help me find the part. 2010FX4offroad 2009 - Present Ford F150 2 02-25-2011 05:04 PM
2004 5.4 with gas smell in the cab and passenger side of motor warren_0127 2004 - 2008 Ford F150 1 01-01-2011 05:33 PM
WTB: Passanger Side Door Handle blackandchrome General F150 Items 0 06-12-2010 11:28 AM

Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 03:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.