saga of the 1995 stuttering f150 - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150
Log In 


saga of the 1995 stuttering f150

Reply
 
 
 
Thread Tools Search this Thread
Old 09-05-2010, 12:12 AM   #1
Junior Member
 
Join Date: Aug 2010
Posts: 18
Thanked 0 Times in 0 Posts
Default saga of the 1995 stuttering f150

i originally posted that my 95 gas f150 5litre would stutter, loose powere. changed gas filter,coil,fuel relay and 02 sensor. did the o2 sensor after i bought the code reader. now i have no faults and it's still doing it. but...... if i switch gas tanks slowly several times it goes away. doesn't matter if i switch back to the original tank, or go to the other. as long a i switch a few times. wierd huh???? any thoughts???dave/sandusky
dwilken is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 09-05-2010, 12:23 AM   #2
We'd do it
5 Year Member
iTrader: (1)
 
Just call me Sean's Avatar
 
Join Date: May 2008
Location: Orlando,Fl.
Posts: 32,385
Thanked 412 Times in 368 Posts
Send a message via Yahoo to Just call me Sean
Default

Do a fuel pressure test.
__________________
Quote:
Originally Posted by Early Cuyler
Fights begin, fingerprints are took, days is lost, bail is made, court dates are ignored, cycle is repeated.
Just call me Sean is online now   Reply With Quote
Old 09-05-2010, 08:15 AM   #3
Administrator
5 Year Member
 
ymeski56's Avatar
 
Join Date: Jul 2008
Location: Long Beach Calimexifornia
Posts: 33,332
Thanked 841 Times in 486 Posts
Default

Which engine? both 300 & 302 are commonly referred to as 5 liters, depending on who your talking to. How many miles on the filter? Regardless of engine, Fuel pressure test is next, as mentioned.
__________________
"Saving the World....One Ford Truck at a Time."
#BlueLivesMatter

Last edited by ymeski56; 09-05-2010 at 08:19 AM.
ymeski56 is online now   Reply With Quote
Old 09-05-2010, 01:49 PM   #4
Junior Member
 
Join Date: Aug 2010
Posts: 18
Thanked 0 Times in 0 Posts
Default thnks

i forgot to list that- that was one of the first things i did- pressure is good- i thought the engine was a 5-just looked it's a 5.8 EFI-dave/ohio
dwilken is offline   Reply With Quote
Old 09-05-2010, 02:57 PM   #5
Senior Member
 
flareside_thunder's Avatar
 
Join Date: Oct 2009
Posts: 1,526
Thanked 3 Times in 3 Posts
Default

I wonder if the tank selector valve could be stickin.......
__________________
Burt- 1989 Ford F250 7.3 NA, Zf, 3.5" Straight Pipe Exhaust, 2001 SuperDuty Axles With 3.73 Gears, 5" Lift Using All Factory Parts, Captain's Chairs, G31 Batteries, NorthStar NS3000 CB With RK56 Mic & 102" SS Whip, Aircraft Landing Lights & 102dB Backup Beeper.
flareside_thunder is offline   Reply With Quote
Old 09-05-2010, 04:32 PM   #6
We'd do it
5 Year Member
iTrader: (1)
 
Just call me Sean's Avatar
 
Join Date: May 2008
Location: Orlando,Fl.
Posts: 32,385
Thanked 412 Times in 368 Posts
Send a message via Yahoo to Just call me Sean
Default

What was the pressure? Engine running? Engine off? Regulator unhooked? Bleed down time?
__________________
Quote:
Originally Posted by Early Cuyler
Fights begin, fingerprints are took, days is lost, bail is made, court dates are ignored, cycle is repeated.
Just call me Sean is online now   Reply With Quote
Old 09-06-2010, 03:13 PM   #7
Junior Member
 
Join Date: Aug 2010
Posts: 18
Thanked 0 Times in 0 Posts
Default i'll have to ask

i'll have to ask my mechanic. i had him check the pressures cause i did't have the equipment-thanks/dave
dwilken is offline   Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
What kind of shocks are you running? SC67 Suspension & Brakes 3 09-12-2015 08:04 AM
Wv f150 mdmosh Introductions 1 09-07-2015 04:00 AM
No Power and stutter at 45-50 again??? vegasdom 2004 - 2008 Ford F150 3 09-07-2015 12:01 AM
Anyone with Rancho rs5000? ericantonio Suspension & Brakes 3 09-05-2015 12:57 AM
Hey everyone Brandyn193 Introductions 1 09-04-2015 04:06 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 01:49 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.