Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150
Sign in using an external account
Register Forgot Password?
Register Garage Photos FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read StoreVendor Directory

Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-09-2011, 04:08 PM   #1
Senior Member
 
Welder7018's Avatar
 
Join Date: Nov 2010
Location: Woodward, Oklahoma
Posts: 13,160
Mentioned: 0 Post(s)
Thanks: 20
Thanked 33 Times in 33 Posts
Feedback Score: 0 reviews
Default MAF sensor on a 1992 4.9l

Here is the MAF located on a 4.9l? And I have a k&n filter
__________________
Jack of all trades
1992 F-250 XL Long bed 5spd 5.8L
1992 F-150 Custom Shortbed 4.9L EFI 5 speed trans
Quote:
Originally Posted by LCB1 View Post
It's just stiff and hard
Lube will always help this
Welder7018 is offline   Reply With Quote
Old 10-09-2011, 04:09 PM   #2
We'd do it
 
Just call me Sean's Avatar
 
Join Date: May 2008
Location: Orlando,Fl.
Posts: 29,949
Mentioned: 2 Post(s)
Thanks: 29
Thanked 330 Times in 295 Posts
Feedback Score: 1 reviews
Send a message via Yahoo to Just call me Sean
Default

There isn't one.
__________________
Quote:
Originally Posted by Early Cuyler
Fights begin, fingerprints are took, days is lost, bail is made, court dates are ignored, cycle is repeated.
Just call me Sean is online now   Reply With Quote
Old 10-09-2011, 04:12 PM   #3
Senior Member
 
Welder7018's Avatar
 
Join Date: Nov 2010
Location: Woodward, Oklahoma
Posts: 13,160
Mentioned: 0 Post(s)
Thanks: 20
Thanked 33 Times in 33 Posts
Feedback Score: 0 reviews
Default

Ok I was wandering because people say the k&n oil will mess it up
__________________
Jack of all trades
1992 F-250 XL Long bed 5spd 5.8L
1992 F-150 Custom Shortbed 4.9L EFI 5 speed trans
Quote:
Originally Posted by LCB1 View Post
It's just stiff and hard
Lube will always help this
Welder7018 is offline   Reply With Quote
Old 10-09-2011, 04:13 PM   #4
We'd do it
 
Just call me Sean's Avatar
 
Join Date: May 2008
Location: Orlando,Fl.
Posts: 29,949
Mentioned: 2 Post(s)
Thanks: 29
Thanked 330 Times in 295 Posts
Feedback Score: 1 reviews
Send a message via Yahoo to Just call me Sean
Default

You're good to go. 4.9s didn't get MAF until '96.
__________________
Quote:
Originally Posted by Early Cuyler
Fights begin, fingerprints are took, days is lost, bail is made, court dates are ignored, cycle is repeated.
Just call me Sean is online now   Reply With Quote
Old 10-09-2011, 04:16 PM   #5
Senior Member
 
Welder7018's Avatar
 
Join Date: Nov 2010
Location: Woodward, Oklahoma
Posts: 13,160
Mentioned: 0 Post(s)
Thanks: 20
Thanked 33 Times in 33 Posts
Feedback Score: 0 reviews
Default

Ok thanks sean
__________________
Jack of all trades
1992 F-250 XL Long bed 5spd 5.8L
1992 F-150 Custom Shortbed 4.9L EFI 5 speed trans
Quote:
Originally Posted by LCB1 View Post
It's just stiff and hard
Lube will always help this
Welder7018 is offline   Reply With Quote
Old 10-09-2011, 04:16 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does the 1992 F150 302 use the MAF sensor Slip 1987 - 1996 F150 10 11-08-2012 08:04 PM
Does anybody know the function of this sensor...is there a sensor? german 2004 - 2008 Ford F150 7 12-23-2010 07:07 PM
1992 f150 4.9 one o2 sensor ? sam2007 1987 - 1996 F150 3 09-01-2010 01:17 AM
Question about Oil pressure sensor,or fake sensor posttal 2004 - 2008 Ford F150 3 03-23-2010 03:24 PM
1992 Won't run at all. jabba 1987 - 1996 F150 2 05-24-2009 11:58 AM

 

The Mustang Source

All times are GMT -4. The time now is 08:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.