Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-09-2011, 05:08 PM   #1
Okie.
 
Welder7018's Avatar
 
Join Date: Nov 2010
Location: Woodward, Oklahoma
Posts: 14,466
Mentioned: 1 Post(s)
Thanked 39 Times in 39 Posts
Feedback Score: 0 reviews
Default MAF sensor on a 1992 4.9l

Here is the MAF located on a 4.9l? And I have a k&n filter
__________________
Jack of all trades
1997 F-150 XLT SuperCab 4x2 4.6L 4r70w
1992 F-150 Custom Shortbed 4.9L EFI 5 speed trans (wrecked)
Quote:
Originally Posted by LCB1 View Post
It's just stiff and hard
Lube will always help this
Welder7018 is offline   Reply With Quote
Old 10-09-2011, 05:09 PM   #2
We'd do it
 
Just call me Sean's Avatar
 
Join Date: May 2008
Location: Orlando,Fl.
Posts: 31,833
Mentioned: 2 Post(s)
Thanked 402 Times in 358 Posts
Feedback Score: 1 reviews
Send a message via Yahoo to Just call me Sean
Default

There isn't one.
__________________
Quote:
Originally Posted by Early Cuyler
Fights begin, fingerprints are took, days is lost, bail is made, court dates are ignored, cycle is repeated.
Just call me Sean is online now   Reply With Quote
Old 10-09-2011, 05:12 PM   #3
Okie.
 
Welder7018's Avatar
 
Join Date: Nov 2010
Location: Woodward, Oklahoma
Posts: 14,466
Mentioned: 1 Post(s)
Thanked 39 Times in 39 Posts
Feedback Score: 0 reviews
Default

Ok I was wandering because people say the k&n oil will mess it up
__________________
Jack of all trades
1997 F-150 XLT SuperCab 4x2 4.6L 4r70w
1992 F-150 Custom Shortbed 4.9L EFI 5 speed trans (wrecked)
Quote:
Originally Posted by LCB1 View Post
It's just stiff and hard
Lube will always help this
Welder7018 is offline   Reply With Quote
Old 10-09-2011, 05:13 PM   #4
We'd do it
 
Just call me Sean's Avatar
 
Join Date: May 2008
Location: Orlando,Fl.
Posts: 31,833
Mentioned: 2 Post(s)
Thanked 402 Times in 358 Posts
Feedback Score: 1 reviews
Send a message via Yahoo to Just call me Sean
Default

You're good to go. 4.9s didn't get MAF until '96.
__________________
Quote:
Originally Posted by Early Cuyler
Fights begin, fingerprints are took, days is lost, bail is made, court dates are ignored, cycle is repeated.
Just call me Sean is online now   Reply With Quote
Old 10-09-2011, 05:16 PM   #5
Okie.
 
Welder7018's Avatar
 
Join Date: Nov 2010
Location: Woodward, Oklahoma
Posts: 14,466
Mentioned: 1 Post(s)
Thanked 39 Times in 39 Posts
Feedback Score: 0 reviews
Default

Ok thanks sean
__________________
Jack of all trades
1997 F-150 XLT SuperCab 4x2 4.6L 4r70w
1992 F-150 Custom Shortbed 4.9L EFI 5 speed trans (wrecked)
Quote:
Originally Posted by LCB1 View Post
It's just stiff and hard
Lube will always help this
Welder7018 is offline   Reply With Quote
Old 10-09-2011, 05:16 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does the 1992 F150 302 use the MAF sensor Slip 1987 - 1996 F150 10 11-08-2012 09:04 PM
Does anybody know the function of this sensor...is there a sensor? german 2004 - 2008 Ford F150 7 12-23-2010 08:07 PM
1992 f150 4.9 one o2 sensor ? sam2007 1987 - 1996 F150 3 09-01-2010 02:17 AM
Question about Oil pressure sensor,or fake sensor posttal 2004 - 2008 Ford F150 3 03-23-2010 04:24 PM
1992 Won't run at all. jabba 1987 - 1996 F150 2 05-24-2009 12:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 02:11 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.