Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-29-2010, 09:55 PM   #1
Member
 
Join Date: Jan 2010
Posts: 98
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Fuel Tank/Gas Gauge Issues

Hi Guys, new to this forum so I don't have any pics up yet, but will get them soon. Anyway I've got a 93' F-150 2wd, 302, long bed, auto. Ever since I bought it from a friend of mine last spring, the front gas tank shows empty no matter how much gas I put in it. Also, when I got it from him, every time I went to add gas to it, the pump at the station would just shut right off like it was full. He said he was never able to put anything in it, that it did the same thing. After messing with it at every fillup, I finally wiggled it around enough and if I hold it just right, it will fill up. Any ideas? I'd love to be able to see how much gas is in there and also be able to fill it up easier. I have a lot of other questions, but this is probably the most annoying right now.

Joe
Joepbj is offline   Reply With Quote
Old 01-29-2010, 10:00 PM   #2
Proud Owner
 
Join Date: Mar 2009
Location: ALASKA
Posts: 446
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

check your fuses, that is all i got to say
cheecks is offline   Reply With Quote
Old 01-29-2010, 10:19 PM   #3
Member
 
Join Date: Jan 2010
Posts: 98
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Any idea where I can find a fuse panel diagram for a 93' F-150?
Joepbj is offline   Reply With Quote
Old 01-30-2010, 12:51 AM   #4
We'd do it
 
Just call me Sean's Avatar
 
Join Date: May 2008
Location: Orlando,Fl.
Posts: 31,321
Mentioned: 2 Post(s)
Thanks: 29
Thanked 373 Times in 333 Posts
Feedback Score: 1 reviews
Send a message via Yahoo to Just call me Sean
Default

Yea, on the fuse panel cover.
__________________
Quote:
Originally Posted by Early Cuyler
Fights begin, fingerprints are took, days is lost, bail is made, court dates are ignored, cycle is repeated.
Just call me Sean is offline   Reply With Quote
Old 01-30-2010, 01:30 AM   #5
Senior Member
 
J.A.C's Avatar
 
Join Date: Dec 2009
Location: Fresno California
Posts: 312
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to J.A.C
Default

does ur gauge works on rear tank
J.A.C is offline   Reply With Quote
Old 01-30-2010, 02:15 AM   #6
Member
 
Join Date: Jan 2010
Posts: 98
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Yea when I switch to the rear tank, the gauge works fine......that's why I never really thought about a fuse being the issue.......but I don't have a wiring diagram to see how the 2 sending units are wired. But there are some other things that don't work that could be fuse issues, like the cruise control not working and the 12v accessory plug not working. I looked on Ford's website and there's an open recall on my truck for the wiring harness but I doubt that has anything to do with any of these issues, but who knows.
Joepbj is offline   Reply With Quote
Old 01-30-2010, 02:30 AM   #7
Senior Member
 
J.A.C's Avatar
 
Join Date: Dec 2009
Location: Fresno California
Posts: 312
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to J.A.C
Default

i have a 93 f150 too 5.0, i have the same problem whit fuel gauge . its the level unit. but the fuel pump and level unit are togehter u have to buy them as one pice, and new fuel pump are expencive plus all the work to removed.i might replace mine this spring what i do now its go by miles on my front tank i reset my odom. every time i fill up and i know i can run about 200 mile befor i have to refill. about the cruise control and 12 v acc. check the fuse . mine blow the same fuse some time when i plug my cell phone charger. and on mine one wire from cruse control wass cut so it was not working , but check fuse first
J.A.C is offline   Reply With Quote
Old 01-30-2010, 09:56 AM   #8
Member
 
Join Date: Jan 2010
Posts: 98
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Thanks JAC, I thought it was probably something like that but was hoping maybe it was just an easy fix. I do the same thing with mine, fill up and when it gets close to 200 I switch tanks. I can live with it but it's just one of those things that pisses you off everytime you drive it. I'm gonna check the fuses for the 12v and C.C. and hope that's the only thing wrong with them.

Is the fuel pump/sending unit inside the tank?
Joepbj is offline   Reply With Quote
Old 01-30-2010, 10:01 AM   #9
Member
 
Join Date: Jan 2010
Posts: 98
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Check this out. Is this what I need?

http://www.car-stuff.com/mmparts/for...fuel_pump.html

It says you can get the level unit separate.
Joepbj is offline   Reply With Quote
Old 01-30-2010, 10:36 AM   #10
Senior Member
 
J.A.C's Avatar
 
Join Date: Dec 2009
Location: Fresno California
Posts: 312
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to J.A.C
Default

yes that the one.but didnt know u can buy it separate. make sure u can unbolt urs ,before u buy it. some time they say it fits ok. but u end up doing some drilling or something else or they r little different. if u can try to get urs out of the tank and see if u can unbolt it
J.A.C is offline   Reply With Quote
Old 01-30-2010, 10:36 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 F-150 XLT Fuel Gage, Fuel Pump, Gas Tank Problems jerome.nichols 1987 - 1996 F150 1 09-03-2009 02:53 AM
1st time using rear fuel tank on new-to-me used '95; tank is not engaging jettboi 1987 - 1996 F150 6 07-28-2009 10:16 AM
gas gauge not working for front tank only cheymiesdad 1987 - 1996 F150 2 12-21-2008 10:23 PM
I have fuel delivery issues from the tank to the engine. wiyo120 1987 - 1996 F150 32 10-09-2008 09:44 PM
I have fuel delivery issues from the tank to the engine. wiyo120 Pre- 1987 / Classic Corner 5 10-07-2008 08:32 PM

Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 05:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.