Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-30-2012, 06:17 PM   #1
Member
 
eddie310's Avatar
 
Join Date: Jan 2012
Posts: 58
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Do you see anything wrong?

Should I rehaul the engine or just add upgrades? It has 210k miles but just came from lake Tahoe I live in In Palo Alto a 4 hour drive and it hauld ***!!!!! Here's a picture of the motor, what do you see wrong?
Attached Thumbnails
Do you see anything wrong?-image-4293940240.jpg   Do you see anything wrong?-image-2744914426.jpg   Do you see anything wrong?-image-980424706.jpg   Do you see anything wrong?-image-596969914.jpg  
eddie310 is offline   Reply With Quote
Old 01-30-2012, 06:24 PM   #2
Member
 
Join Date: Dec 2011
Location: Burnsville, MN
Posts: 61
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Yes, the paint is peeling on the motor.
whoneeds8? is offline   Reply With Quote
Old 01-30-2012, 06:32 PM   #3
It's a Canadian thing eh!
 
sylver91's Avatar
 
Join Date: Nov 2010
Location: Ontario, living across a hay field
Posts: 6,663
Mentioned: 13 Post(s)
Thanked 183 Times in 178 Posts
Feedback Score: 0 reviews
Default

Rusty EGR? Missing throttle body cover, dirty hood, some crusty vacuum hose?
__________________
96 300ci M5OD 2wd Reg Cab Long Bed 3.31 LS Gears and 8-Track player

A question that sometimes drives me hazy: am I or are the others crazy?
Albert Einstein
sylver91 is offline   Reply With Quote
Old 01-30-2012, 07:18 PM   #4
Senior Member
 
MonsterinWI's Avatar
 
Join Date: Aug 2011
Location: Wisconsin
Posts: 439
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Apparently was maintained well, for over 200k that motor is pretty clean. Then again mine was a farm truck so everything is amazingly clean to me lol.
MonsterinWI is offline   Reply With Quote
Old 01-30-2012, 08:02 PM   #5
Member
 
Join Date: Dec 2011
Location: Ames, Iowa
Posts: 32
Mentioned: 0 Post(s)
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Whats wrong here?

EGR still attached, vacuum pump still attached, vacuum hoses running everywhere. lol


@ that mileage I'd say do a rebuild... I bet you would be amazed at how you'll love your truck again.
MikeNorris is offline   Reply With Quote
Old 01-30-2012, 08:42 PM   #6
Junior Member
 
Join Date: Dec 2011
Location: NL
Posts: 21
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Check to see if the recall on your cruise control was done, I don't see a fuseable link there. The cruise control was known to cause the odd fire.
bubbasdad is offline   Reply With Quote
Old 01-30-2012, 09:18 PM   #7
Senior Member
 
Join Date: Oct 2011
Posts: 216
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by MikeNorris View Post
Whats wrong here?

EGR still attached, vacuum pump still attached, vacuum hoses running everywhere. lol


@ that mileage I'd say do a rebuild... I bet you would be amazed at how you'll love your truck again.

gonna have to leave all that in living in California.
nemesiss45 is offline   Reply With Quote
Old 01-30-2012, 09:28 PM   #8
Member
 
eddie310's Avatar
 
Join Date: Jan 2012
Posts: 58
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by MikeNorris
Whats wrong here?

EGR still attached, vacuum pump still attached, vacuum hoses running everywhere. lol

@ that mileage I'd say do a rebuild... I bet you would be amazed at how you'll love your truck again.
So your saying I should remove the vacuum hoses?
eddie310 is offline   Reply With Quote
Old 01-30-2012, 10:44 PM   #9
Senior Member
 
fordka's Avatar
 
Join Date: Nov 2011
Location: boonville ny
Posts: 2,204
Mentioned: 0 Post(s)
Thanked 20 Times in 20 Posts
Feedback Score: 0 reviews
Default

your intake is blue
fordka is offline   Reply With Quote
Old 01-31-2012, 01:29 AM   #10
Senior Member
 
Join Date: Jan 2011
Posts: 586
Mentioned: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

I wouldn't do anything to it until something breaks. Unless you're looking for better performance of course.
joshtowal is offline   Reply With Quote
Old 01-31-2012, 01:29 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
What am I doing wrong? HoppyFX4 2004 - 2008 Ford F150 3 11-23-2011 09:53 PM
Something wrong.... Frickalick 1997 - 2003 Ford F150 3 05-24-2011 04:57 AM
anything wrong with this? thetruck 1997 - 2003 Ford F150 4 11-14-2010 12:31 AM
Is something wrong if.... nunchakyo 1997 - 2003 Ford F150 2 06-30-2010 09:38 AM
wrong gas 074X2LARRY General F150 Discussion 6 04-20-2010 08:52 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 11:56 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.