Changed fuel filter and fuel pump, 96 F150 still won't start - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150
Log In 


Changed fuel filter and fuel pump, 96 F150 still won't start

Reply
 
 
 
 
Thread Tools Search this Thread
Old 01-31-2012, 07:29 PM   #1
Junior Member
 
Join Date: Jan 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Changed fuel filter and fuel pump, 96 F150 still won't start

It sounds like it is trying to start but it won't. I put in a new fuel filter first. A lot of people told me it sounds like the fuel pump so I changed that and it still won't start.

Any ideas on what else it could be?
jaderbing is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 02-01-2012, 04:47 AM   #2
Senior Member
 
Join Date: Oct 2011
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

have you checked your fuel pressure? you need to know if you are getting adequate pressure to the injectors.

also, which pump did you replace? there are more than one.
nemesiss45 is offline   Reply With Quote
Old 02-01-2012, 08:04 AM   #3
Senior Member
 
Join Date: Jan 2011
Posts: 696
Thanks: 0
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Default

Have you tried switching to the other tank? That would tell you pretty quick if it's a fuel pump. Not likely for both to go out at the exact same time. It could be something as simple as a fuse or a relay. Replace both of those with known good. There are plenty of similar fuses and relays in the fuse box to borrow so you can check it. Check the voltage at the wiring harness that the fuel pump hanger assembly hooks in to to make sure you're actually getting power to it. If you aren't, check the other tank as well.
joshtowal is offline   Reply With Quote
Old 02-01-2012, 10:30 AM   #4
Mark
5 Year Member
 
techrep's Avatar
 
Join Date: Jan 2009
Location: Va. Beach, VA.
Posts: 20,256
Thanked 586 Times in 519 Posts
Feedback Score: 1 reviews
Default

Fuel pump relay ??
__________________
08 FX4... Flowmaster Exhaust, line-X, Sky Jacker leveling kit. 295/65/20 Nitto trails mounted on 20 X 9 Carol Shelby wheels. AIRAID CAI. Harley headlamps and LED Tails & 3rd brake lights,custom upper and lower Grill. Edge Evolution. Interior/Exterior LED lighting, NFAB step bars.
techrep is offline   Reply With Quote
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 06:11 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.