'95 Speed sensor location - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150
Log In 


'95 Speed sensor location

Reply
 
 
 
 
Thread Tools Search this Thread
Old 03-21-2010, 03:26 PM   #1
Member
 
Join Date: Dec 2009
Location: currently Yuma, AZ
Posts: 37
Feedback Score: 0 reviews
Thanks: 0
Thanked 0 Times in 0 Posts
Default '95 Speed sensor location

I have a '95 F150 4x4 with the 302. It shifts hard when I accelerate and I was told by someone on here that he had the same problem and replacing the speed sensor fixed it. Where is the speed sensor at and what tools do I need to replace it?
jjt_33 is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 03-21-2010, 04:18 PM   #2
Administrator
5 Year Member
 
ymeski56's Avatar
 
Join Date: Jul 2008
Location: Long Beach Calimexifornia
Posts: 32,858
Feedback Score: 0 reviews
Thanked 794 Times in 455 Posts
Default

On top of your differential but that's not the problem, if that's your only symptom. Error code scan could help. Your tranny is computer integrated. When was tranny serviced last?
__________________
"Saving the World....One Ford Truck at a Time."
#BlueLivesMatter
ymeski56 is offline   Reply With Quote
Old 03-21-2010, 04:40 PM   #3
Member
 
Join Date: Dec 2009
Location: currently Yuma, AZ
Posts: 37
Feedback Score: 0 reviews
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Scan's turn up nothing. I'm not sure when it was last serviced, I've had it about two years now. The fluid's still a good color, I don't know how to do anything else for the tranny
jjt_33 is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 xlt 5.4 with chirp/squeal while drive belt off I'dRatherBfishing General F150 Discussion 4 12-16-2015 05:35 PM
20" 2015 Platinum wheels for sale jt2002hd 2015 - Present Part Sales 17 11-16-2015 06:20 AM
speedometer jumping teel51 1987 - 1996 F150 1 09-08-2015 08:35 PM
Want to Buy [Canada]: Black front and rear bumpers for 2013 F150 ValK 2009 - 2014 Part Sales 0 09-07-2015 12:22 PM
1997 F-150 Vehicle Speed Sensor Intermittent KnightIRD 1997 - 2003 Ford F150 2 09-05-2015 06:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 05:01 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.