Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-06-2012, 03:55 PM   #1
bigjon69420
 
Join Date: Oct 2011
Location: greenville pa 16125
Posts: 2
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 94 f150 supercab 4.9 bad gas mileage no power

i have a 94 f150 4x4- 4.9 with 189k on the clock. its got the 5 speed came factory with 308 differential but swapped them out for 355. i thought this mite solve the power problem but it did'nt really help much. i had problem at in town speeds with the truck surging and found out on this site it was the egr valve so i put a plate between the egr and the manofold.. it stopped the surging.. but i cant seem to get more the 10.5 miles a gallon out of it i keep it under 2000rpms unless im at highway speeds at 65 it sits at 2150 with the 355's.... i was thinking it mite be the cataladic convertor. the hose that is in front of the convertor rusted out i think it goes up to the smog pump i tried patching it with fence wire and several layers of jb weld held great for a week until i hauled my camper and truck got pretty hot not overheated i was thinking the converter mite be plugged and making back pressure blowing out the jb weld also i can hear exhause under the hood not from the donuts but from the air pump. the temp gauge never worked so i put a new sensor in it still didnt work so i put in a manual gauge. i heard someone mention that if the temp gauge for the computer is'nt working the engine will run rich. if i put my hand behiond muffler the exhaust gas seems hotter then it should be. i love this truch just wish i coud get better mileage. would blocking egr val;ve make me lose4 power and mileage?? i was thinking of taking exhaust off and punching oput the convertor. any advice????
bigjon69420 is offline   Reply With Quote
Old 10-06-2012, 03:58 PM   #2
bigjon69420
 
Join Date: Oct 2011
Location: greenville pa 16125
Posts: 2
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

forgot to mention i did plugs,wires,cap,rotor, full fluid change, air filter, fuel filter,
bigjon69420 is offline   Reply With Quote
Old 10-06-2012, 03:58 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 05:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.