Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 02-20-2013, 01:30 AM   #1
Junior Member
 
Join Date: Feb 2013
Posts: 3
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 1989 f150 5.0l backfires through intake

Hi everyone I am having a problem with my 89 f150 with a 5.0l in it. This problem just stared this winter. When I go to rev truck up just sitting from about 1000 to 2000 rpm it will cutout bad and eventually backfire through intake sometimes it will just almost die. But if I rev it up more it pulls out of it and revs fine until i let it idle again and then rev it. I have replaced fuel filter and cleaned egr valve out still no sign of getting better. When I go to drive the truck I have to slip the clutch bad just to get it to drive and everytime I shift from 1000 to 2000 rpm the truck will barely drive but after I get it past that rpm it will drive fine until I upshift again then it falls on its face. It seems when I have even more of a load it won't move at all it just tries to die like if i put it in 4 wheel drive i cant get the truck to move but it never dies just has no power what so ever and won't pull itself.
mathaw is offline   Reply With Quote
Old 02-20-2013, 01:30 AM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 08:58 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.